// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\s*\d+\s*$(?:\r?\n?)+^\s*([\d:,\.]+)\s*-->\s*([\d:,\.]+)\s*$(?:\r?\n?)+((?:.*(?:\r?\n?)?)*?)(?:\r\n|\r|\n|$)").unwrap();
let string = "
00:00:02,070 --> 00:00:8,572
(<i> explosion and number of members</i> )
(<i> inaudible radio chatter</i> )";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}