package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*\d+\s*$(?:\r?\n?)+^\s*([\d:,\.]+)\s*-->\s*([\d:,\.]+)\s*$(?:\r?\n?)+((?:.*(?:\r?\n?)?)*?)(?:\r\n|\r|\n|$)`)
var str = `
00:00:02,070 --> 00:00:8,572
(<i> explosion and number of members</i> )
(<i> inaudible radio chatter</i> )`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}