import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\d+\\s*$(?:\\r?\\n?)+^\\s*([\\d:,\\.]+)\\s*-->\\s*([\\d:,\\.]+)\\s*$(?:\\r?\\n?)+((?:.*(?:\\r?\\n?)?)*?)(?:\\r\\n|\\r|\\n|$)";
final String string = "\n"
+ "00:00:02,070 --> 00:00:8,572\n"
+ "(<i> explosion and number of members</i> ) \n"
+ "(<i> inaudible radio chatter</i> )";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}