const regex = /^\s*\d+\s*$(?:\r?\n?)+^\s*([\d:,\.]+)\s*-->\s*([\d:,\.]+)\s*$(?:\r?\n?)+((?:.*(?:\r?\n?)?)*?)(?:\r\n|\r|\n|$)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*\\d+\\s*$(?:\\r?\\n?)+^\\s*([\\d:,\\.]+)\\s*-->\\s*([\\d:,\\.]+)\\s*$(?:\\r?\\n?)+((?:.*(?:\\r?\\n?)?)*?)(?:\\r\\n|\\r|\\n|$)', '')
const str = `
00:00:02,070 --> 00:00:8,572
(<i> explosion and number of members</i> )
(<i> inaudible radio chatter</i> )`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}