using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*\d+\s*$(?:\r?\n?)+^\s*([\d:,\.]+)\s*-->\s*([\d:,\.]+)\s*$(?:\r?\n?)+((?:.*(?:\r?\n?)?)*?)(?:\r\n|\r|\n|$)";
string input = @"
00:00:02,070 --> 00:00:8,572
(<i> explosion and number of members</i> )
(<i> inaudible radio chatter</i> )";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}