// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/(watch\?v=|embed\/)([\d\w-_]+)").unwrap();
let string = "aaa@adasd.com
adas@asdas.com.br
https://www.youtube.com/watch?v=C8UMTmUbxTI
http://www.youtube.com/watch?v=C8UMTmUbxTI
www.youtube.com/embed/C8UMTmUbxTI
www.youtube.com.br/embed/C8UMTmUbxTI?rel=0
m.youtube.com/watch?v=C8UMTmUbxTI";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}