use strict;
my $str = 'aaa@adasd.com
adas@asdas.com.br
https://www.youtube.com/watch?v=C8UMTmUbxTI
http://www.youtube.com/watch?v=C8UMTmUbxTI
www.youtube.com/embed/C8UMTmUbxTI
www.youtube.com.br/embed/C8UMTmUbxTI?rel=0
m.youtube.com/watch?v=C8UMTmUbxTI';
my $regex = qr/\/(watch\?v=|embed\/)([\d\w-_]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}