package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/(watch\?v=|embed\/)([\d\w-_]+)`)
var str = `aaa@adasd.com
adas@asdas.com.br
https://www.youtube.com/watch?v=C8UMTmUbxTI
http://www.youtube.com/watch?v=C8UMTmUbxTI
www.youtube.com/embed/C8UMTmUbxTI
www.youtube.com.br/embed/C8UMTmUbxTI?rel=0
m.youtube.com/watch?v=C8UMTmUbxTI`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}