const regex = /\/(watch\?v=|embed\/)([\d\w-_]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(watch\\?v=|embed\\\/)([\\d\\w-_]+)', 'gm')
const str = `aaa@adasd.com
adas@asdas.com.br
https://www.youtube.com/watch?v=C8UMTmUbxTI
http://www.youtube.com/watch?v=C8UMTmUbxTI
www.youtube.com/embed/C8UMTmUbxTI
www.youtube.com.br/embed/C8UMTmUbxTI?rel=0
m.youtube.com/watch?v=C8UMTmUbxTI`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}