re = /\/(watch\?v=|embed\/)([\d\w-_]+)/m
str = 'aaa@adasd.com
adas@asdas.com.br
https://www.youtube.com/watch?v=C8UMTmUbxTI
http://www.youtube.com/watch?v=C8UMTmUbxTI
www.youtube.com/embed/C8UMTmUbxTI
www.youtube.com.br/embed/C8UMTmUbxTI?rel=0
m.youtube.com/watch?v=C8UMTmUbxTI'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end