import Foundation
let pattern = #"\$\S+(*SKIP)(*F)|(.)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Example \%^ $variable"SHOULDMATCH ${array[$element]}SHOULDMATCH"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)