# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\$\S+(*SKIP)(*F)|(.)/\\$1/g;t' <<< "Example \%^ $variable\"SHOULDMATCH ${array[$element]}SHOULDMATCH"