#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\$\S+(*SKIP)(*F)|(.)"
Local $sString = "Example \%^ $variable"SHOULDMATCH ${array[$element]}SHOULDMATCH"
Local $sSubst = "\\$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)