$re = '/\$\S+(*SKIP)(*F)|(.)/';
$str = 'Example \\%^ $variable"SHOULDMATCH ${array[$element]}SHOULDMATCH';
$subst = "\\$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;