using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$\S+(*SKIP)(*F)|(.)";
string substitution = @"\\$1";
string input = @"Example \%^ $variable""SHOULDMATCH ${array[$element]}SHOULDMATCH";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}