# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div class=\"form-group\">\s*<label for=\"(\S*)\">(.*)<\/label>\s*<input type=\"text\" class=\"form-control\" id=\"(.*)\" placeholder=\"(.*)\" ng-model=\"(.*)\">\s*<\/div>"
test_str = ("<div class=\"form-group\">\n"
" <label for=\"ENG1\">Pattern Design</label>\n"
" <input type=\"text\" class=\"form-control\" id=\"ENG1\" placeholder=\"...\" ng-model=\"currentForm.form10e.ENG1\"> \n"
" </div>")
subst = "<div class=\"form-group\">\\n\\t<div class=\"form-inline\">\\n\\t\\t<div class=\"item item-input\" for=\"\\1\">\\n\\t\\t<span class=\"input-label\">\\2</span>\\n\\t\\t<input type=\"text\" class=\"form-control\" id=\"\\3\" placeholder=\"\\4\" ng-model=\"\\5\">\\n\\t\\t</div>\\n\\t</div>\\n</div>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.