import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"form-group\">\\s*<label for=\"(\\S*)\">(.*)<\\/label>\\s*<input type=\"text\" class=\"form-control\" id=\"(.*)\" placeholder=\"(.*)\" ng-model=\"(.*)\">\\s*<\\/div>";
final String string = "<div class=\"form-group\">\n"
+ " <label for=\"ENG1\">Pattern Design</label>\n"
+ " <input type=\"text\" class=\"form-control\" id=\"ENG1\" placeholder=\"...\" ng-model=\"currentForm.form10e.ENG1\"> \n"
+ " </div>";
final String subst = "<div class=\"form-group\">\\n\\t<div class=\"form-inline\">\\n\\t\\t<div class=\"item item-input\" for=\"\\1\">\\n\\t\\t<span class=\"input-label\">\\2</span>\\n\\t\\t<input type=\"text\" class=\"form-control\" id=\"\\3\" placeholder=\"\\4\" ng-model=\"\\5\">\\n\\t\\t</div>\\n\\t</div>\\n</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}