using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""form-group"">\s*<label for=""(\S*)"">(.*)<\/label>\s*<input type=""text"" class=""form-control"" id=""(.*)"" placeholder=""(.*)"" ng-model=""(.*)"">\s*<\/div>";
string substitution = @"<div class=""form-group"">\n\t<div class=""form-inline"">\n\t\t<div class=""item item-input"" for=""\1"">\n\t\t<span class=""input-label"">\2</span>\n\t\t<input type=""text"" class=""form-control"" id=""\3"" placeholder=""\4"" ng-model=""\5"">\n\t\t</div>\n\t</div>\n</div>";
string input = @"<div class=""form-group"">
<label for=""ENG1"">Pattern Design</label>
<input type=""text"" class=""form-control"" id=""ENG1"" placeholder=""..."" ng-model=""currentForm.form10e.ENG1"">
</div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}