$re = '/<div class="form-group">\s*<label for="(\S*)">(.*)<\/label>\s*<input type="text" class="form-control" id="(.*)" placeholder="(.*)" ng-model="(.*)">\s*<\/div>/';
$str = '<div class="form-group">
<label for="ENG1">Pattern Design</label>
<input type="text" class="form-control" id="ENG1" placeholder="..." ng-model="currentForm.form10e.ENG1">
</div>';
$subst = "<div class=\"form-group\">\n\t<div class=\"form-inline\">\n\t\t<div class=\"item item-input\" for=\"\1\">\n\t\t<span class=\"input-label\">\2</span>\n\t\t<input type=\"text\" class=\"form-control\" id=\"\3\" placeholder=\"\4\" ng-model=\"\5\">\n\t\t</div>\n\t</div>\n</div>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;