import Foundation
let pattern = #"[^\s.](?:[^?.]|\.(?! ))*\?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
now"? She said, "I feel great". Then I said to her, "All right, would
you mind leaving the room for a minute or two? This is part of the
exercise". So she did. While she was away, I said to the others in the
therapy group, "I am still the provincial superior, O.K.?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)