using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\s.](?:[^?.]|\.(?! ))*\?";
string input = @"now""? She said, ""I feel great"". Then I said to her, ""All right, would
you mind leaving the room for a minute or two? This is part of the
exercise"". So she did. While she was away, I said to the others in the
therapy group, ""I am still the provincial superior, O.K.? ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}