#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^\s.](?:[^?.]|\.(?! ))*\?"
Local $sString = "now"? She said, "I feel great". Then I said to her, "All right, would " & @CRLF & _
"you mind leaving the room for a minute or two? This is part of the " & @CRLF & _
"exercise". So she did. While she was away, I said to the others in the " & @CRLF & _
"therapy group, "I am still the provincial superior, O.K.? "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")