re = /[^\s.](?:[^?.]|\.(?! ))*\?/m
str = 'now"? She said, "I feel great". Then I said to her, "All right, would
you mind leaving the room for a minute or two? This is part of the
exercise". So she did. While she was away, I said to the others in the
therapy group, "I am still the provincial superior, O.K.? '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end