import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\s.](?:[^?.]|\\.(?! ))*\\?";
final String string = "now\"? She said, \"I feel great\". Then I said to her, \"All right, would \n"
+ "you mind leaving the room for a minute or two? This is part of the \n"
+ "exercise\". So she did. While she was away, I said to the others in the \n"
+ "therapy group, \"I am still the provincial superior, O.K.? ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}