$re = '/(_)([^_]+)(\..{3})$/m';
$str = 'windows10.0-kb4485448-x64_e43307ad84b7df662be562eafc70e0b081dffc38.msu
windows10.0-kb4487017-x64_delta_0718751eb60b786cda40725bda3e09e26374d83c.msu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);