package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(_)([^_]+)(\..{3})$`)
var str = `windows10.0-kb4485448-x64_e43307ad84b7df662be562eafc70e0b081dffc38.msu
windows10.0-kb4487017-x64_delta_0718751eb60b786cda40725bda3e09e26374d83c.msu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}