use strict;
my $str = 'windows10.0-kb4485448-x64_e43307ad84b7df662be562eafc70e0b081dffc38.msu
windows10.0-kb4487017-x64_delta_0718751eb60b786cda40725bda3e09e26374d83c.msu';
my $regex = qr/(_)([^_]+)(\..{3})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}