import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(_)([^_]+)(\\..{3})$";
final String string = "windows10.0-kb4485448-x64_e43307ad84b7df662be562eafc70e0b081dffc38.msu\n"
+ "windows10.0-kb4487017-x64_delta_0718751eb60b786cda40725bda3e09e26374d83c.msu";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}