const regex = /(_)([^_]+)(\..{3})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(_)([^_]+)(\\..{3})$', 'gm')
const str = `windows10.0-kb4485448-x64_e43307ad84b7df662be562eafc70e0b081dffc38.msu
windows10.0-kb4487017-x64_delta_0718751eb60b786cda40725bda3e09e26374d83c.msu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}