re = /(?!$)[123]{0,1}\d(\.\d{1,2})(?!(\s){0,3}%)/m
str = '14.2
1.5
1002
4.3
6.3%
32.1 %
$100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end