using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!$)[123]{0,1}\d(\.\d{1,2})(?!(\s){0,3}%)";
string input = @"14.2
1.5
1002
4.3
6.3%
32.1 %
$100";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}