import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!$)[123]{0,1}\\d(\\.\\d{1,2})(?!(\\s){0,3}%)";
final String string = "14.2\n"
+ "1.5\n"
+ "1002\n"
+ "4.3\n"
+ "6.3%\n"
+ "32.1 %\n"
+ "$100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}