#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!$)[123]{0,1}\d(\.\d{1,2})(?!(\s){0,3}%)"
Local $sString = "14.2" & @CRLF & _
"1.5" & @CRLF & _
"1002" & @CRLF & _
"4.3" & @CRLF & _
"6.3%" & @CRLF & _
"32.1 %" & @CRLF & _
"$100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")