use strict;
my $str = '14.2
1.5
1002
4.3
6.3%
32.1 %
$100';
my $regex = qr/(?!$)[123]{0,1}\d(\.\d{1,2})(?!(\s){0,3}%)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}