import Foundation
let pattern = #""(?:[^"]|"")*"|[^,\n]+|(?=,)(?<=,)|^|(?<=,)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
record 1:field 1,record 1:field 2,record 1:field 3
record 2:field 1,record 2:field 2,record 2:field 3
"quoted field","quoted field, with comma", "whitespace before & affer quote" ,"new
line in field","double quotes ""in"" field","double quotes in field "","" with comma"
,,,<- empty fields at beging, , ,<-whitespace fields,empty fields at end ->,,
^empty records
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)