re = /"(?:[^"]|"")*"|[^,\n]+|(?=,)(?<=,)|^|(?<=,)$/m
str = 'record 1:field 1,record 1:field 2,record 1:field 3
record 2:field 1,record 2:field 2,record 2:field 3
"quoted field","quoted field, with comma", "whitespace before & affer quote" ,"new
line in field","double quotes ""in"" field","double quotes in field "","" with comma"
,,,<- empty fields at beging, , ,<-whitespace fields,empty fields at end ->,,
^empty records'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end