using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(?:[^""]|"")*""|[^,\n]+|(?=,)(?<=,)|^|(?<=,)$";
string input = @"record 1:field 1,record 1:field 2,record 1:field 3
record 2:field 1,record 2:field 2,record 2:field 3
""quoted field"",""quoted field, with comma"", ""whitespace before & affer quote"" ,""new
line in field"",""double quotes ""in"" field"",""double quotes in field "","" with comma""
,,,<- empty fields at beging, , ,<-whitespace fields,empty fields at end ->,,
^empty records";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}