import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?:[^\"]|\"\")*\"|[^,\\n]+|(?=,)(?<=,)|^|(?<=,)$";
final String string = "record 1:field 1,record 1:field 2,record 1:field 3\n"
+ "record 2:field 1,record 2:field 2,record 2:field 3\n"
+ "\"quoted field\",\"quoted field, with comma\", \"whitespace before & affer quote\" ,\"new\n"
+ "line in field\",\"double quotes \"\"in\"\" field\",\"double quotes in field \"\",\"\" with comma\"\n"
+ ",,,<- empty fields at beging, , ,<-whitespace fields,empty fields at end ->,,\n\n\n"
+ "^empty records";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}