// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)roll (\d+)d(\d+)([\+-]\d+)?$").unwrap();
let string = "roll 1d10
roll 1d100
roll 1d20
roll 1d1234
roll 1d20+1
roll 1d20-1
roll 1d20*1
roll 1d20a1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}