const regex = /roll (\d+)d(\d+)([\+-]\d+)?$/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('roll (\\d+)d(\\d+)([\\+-]\\d+)?$', 'ig')
const str = `roll 1d10
roll 1d100
roll 1d20
roll 1d1234
roll 1d20+1
roll 1d20-1
roll 1d20*1
roll 1d20a1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}