use strict;
my $str = 'roll 1d10
roll 1d100
roll 1d20
roll 1d1234
roll 1d20+1
roll 1d20-1
roll 1d20*1
roll 1d20a1
';
my $regex = qr/roll (\d+)d(\d+)([\+-]\d+)?$/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}