import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "roll (\\d+)d(\\d+)([\\+-]\\d+)?$";
final String string = "roll 1d10\n"
+ "roll 1d100\n"
+ "roll 1d20\n"
+ "roll 1d1234\n"
+ "roll 1d20+1\n"
+ "roll 1d20-1\n"
+ "roll 1d20*1\n"
+ "roll 1d20a1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}