re = /roll (\d+)d(\d+)([\+-]\d+)?$/i
str = 'roll 1d10
roll 1d100
roll 1d20
roll 1d1234
roll 1d20+1
roll 1d20-1
roll 1d20*1
roll 1d20a1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end