re = /^\+?(0*[1-9]\d*(?:[\., ]\d+)*) *(?:\p{Sc}|°[FC])?$/m
str = 'All real numbers can be divided into three categories: positive, negative and zero;
Match all positive number
Match:
2
9
+8
005
0420
123456789
40.262,12
+042 262,12
421.265.195,52
0420 $
0420 €
35 °C
12 °F
No Match:
0
00000 0000
-10
-1
10a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end