import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?(0*[1-9]\\d*(?:[\\., ]\\d+)*) *(?:\\p{Sc}|°[FC])?$";
final String string = "All real numbers can be divided into three categories: positive, negative and zero;\n"
+ "Match all positive number\n\n"
+ "Match:\n"
+ "2\n"
+ "9 \n"
+ "+8\n"
+ "005\n"
+ "0420\n"
+ "123456789\n"
+ "40.262,12\n"
+ "+042 262,12\n"
+ "421.265.195,52\n"
+ "0420 $\n"
+ "0420 €\n"
+ "35 °C\n"
+ "12 °F\n\n"
+ "No Match:\n"
+ "0\n"
+ "00000 0000\n"
+ "-10\n"
+ "-1\n"
+ "10a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}