const regex = /^\+?(0*[1-9]\d*(?:[\., ]\d+)*) *(?:\p{Sc}|°[FC])?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?(0*[1-9]\\d*(?:[\\., ]\\d+)*) *(?:\\p{Sc}|°[FC])?$', 'mg')
const str = `All real numbers can be divided into three categories: positive, negative and zero;
Match all positive number
Match:
2
9
+8
005
0420
123456789
40.262,12
+042 262,12
421.265.195,52
0420 \$
0420 €
35 °C
12 °F
No Match:
0
00000 0000
-10
-1
10a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}