#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+?(0*[1-9]\d*(?:[\., ]\d+)*) *(?:\p{Sc}|°[FC])?$"
Local $sString = "All real numbers can be divided into three categories: positive, negative and zero;" & @CRLF & _
"Match all positive number" & @CRLF & _
"" & @CRLF & _
"Match:" & @CRLF & _
"2" & @CRLF & _
"9 " & @CRLF & _
"+8" & @CRLF & _
"005" & @CRLF & _
"0420" & @CRLF & _
"123456789" & @CRLF & _
"40.262,12" & @CRLF & _
"+042 262,12" & @CRLF & _
"421.265.195,52" & @CRLF & _
"0420 $" & @CRLF & _
"0420 €" & @CRLF & _
"35 °C" & @CRLF & _
"12 °F" & @CRLF & _
"" & @CRLF & _
"No Match:" & @CRLF & _
"0" & @CRLF & _
"00000 0000" & @CRLF & _
"-10" & @CRLF & _
"-1" & @CRLF & _
"10a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")