using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+?(0*[1-9]\d*(?:[\., ]\d+)*) *(?:\p{Sc}|°[FC])?$";
string input = @"All real numbers can be divided into three categories: positive, negative and zero;
Match all positive number
Match:
2
9
+8
005
0420
123456789
40.262,12
+042 262,12
421.265.195,52
0420 $
0420 €
35 °C
12 °F
No Match:
0
00000 0000
-10
-1
10a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}