import Foundation
let pattern = #"[,](?![^(]*\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"&relations=categories.materials.(frbr_equivilents,list_alternatives,tags,ratings),descendants,ancestors"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)