# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[,](?![^(]*\))//g;t' <<< "&relations=categories.materials.(frbr_equivilents,list_alternatives,tags,ratings),descendants,ancestors"